ホーム>source

誰かがjboss互換性マトリックスがJava 10であるかどうかを見つけることができる場所を指し示すことができますか?

wildfly 9.0.2最終バージョンを使用しています。これはJava 10と互換性がありますか?

よろしく、 ヴィベック

あなたの答え
  • 解決した方法 # 1

    Wildfly 9.0.2は2015年10月26日にリリースされました-http://wildfly.org/news/2015/10/26/WildFly902-Released/

    Java 10は2018年3月20日にリリースされました-https://www.oracle.com/corporate/pressrelease/Java-10-032018.html。

    したがって、Wildfly 9.0.2はJDK 10でコンパイルされたJavaコードを実行できると信じる理由はありません。

    その後も- JAVA_HOME="/opt/java/..." を設定して、WildflyをカスタムJVMで実行するように設定できます  で standalone.conf  ファイル。 Javaはバイナリの下位互換性があるため、理論的にはこれで機能します。

  • 前へ java - JPAクエリ:サブクエリをグループ化条件に結合する
  • 次へ xamarin - C#、Android:独自のイベントリスナーを構築する