ホーム>source

私のバージョンは6.10 Oracle Linuxです

x86_64とi686の両方のパッケージをインストールしようとしています glibcパッケージを手動でインストールしようとしています

yum install glibc-2.12-1.192.el6.i686
Loaded plugins: pulp-profile-update, security, ulninfo
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.12-1.192.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.192.el6 for package: glibc-2.12-1.192.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.192.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.192.el6.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.192.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.192.el6 for package: glibc-2.12-1.192.el6.i686
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.el6_8 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.192.el6.i686 (nap_latest)
           Requires: glibc-common = 2.12-1.192.el6
           Installed: glibc-common-2.12-1.212.0.1.el6.x86_64 (@OL6Latest-x86_64/6.9)
               glibc-common = 2.12-1.212.0.1.el6
           Available: glibc-common-2.12-1.80.el6.x86_64 (nap_ol_base)
               glibc-common = 2.12-1.80.el6
           Available: glibc-common-2.12-1.107.el6_4.5.x86_64 (nap_latest)
               glibc-common = 2.12-1.107.el6_4.5
           Available: glibc-common-2.12-1.132.el6.x86_64 (nap_latest)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.132.el6_5.2.x86_64 (nap_latest)
               glibc-common = 2.12-1.132.el6_5.2
           Available: glibc-common-2.12-1.132.el6_5.4.x86_64 (nap_latest)
               glibc-common = 2.12-1.132.el6_5.4
           Available: glibc-common-2.12-1.149.el6.x86_64 (nap_latest)
               glibc-common = 2.12-1.149.el6
           Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (nap_latest)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (nap_latest)
               glibc-common = 2.12-1.149.el6_6.9
           Available: glibc-common-2.12-1.166.el6_7.3.x86_64 (nap_latest)
               glibc-common = 2.12-1.166.el6_7.3
           Available: glibc-common-2.12-1.166.el6_7.7.x86_64 (nap_latest)
               glibc-common = 2.12-1.166.el6_7.7
           Available: glibc-common-2.12-1.192.el6.x86_64 (nap_latest)
               glibc-common = 2.12-1.192.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

何か案は?これを見た人はいますか?

あなたの答え
  • 解決した方法 # 1

    glibc-2.12-1.192.el6.i686 をインストールできません  および glibc-2.12-1.212.0.1.el6.x86_64  並行して。 glibc-2.12-1.192.el6.x86_64 にダウングレードする必要があります 。適切なリポジトリー構成で、これは機能するはずです:

    yum downgrade glibc-2.12-1.192.el6.x86_64
    
    

    ただし、 yum upgrade を実行する方がおそらく簡単です  そして、単に glibc.i686 をインストールします 、明示的なバージョンなし。

    2.12-1.212.0.1.el6  ところで、奇妙なバージョンです。 Oracleがそこで何をしているかわからない。)

  • 解決した方法 # 2

    OK、これを機能させるためにしたことです:

    yum -y downgrade glibc glibc-common
    yum install -y glibc.i686   glibc-devel.i686  glibc-devel.x86_64 glibc-headers.x86_64
    
    

    次のようなものが必要です。

    glibc.i686                       
    glibc.x86_64                     
    glibc-common.x86_64              
    glibc-devel.i686                 
    glibc-devel.x86_64               
    glibc-headers.x86_64
    
    

    それでも問題がある場合は、リポジトリを確認してください

関連記事

  • 前へ java - JPAクエリ:サブクエリをグループ化条件に結合する
  • 次へ Pythonを使用してWebサイトにログインする